Problème de couleurs

Aller en bas

Problème de couleurs

Message par dragonjoker le Mar 20 Nov - 12:26

Je viens de refaire le design du forum que j'administre, et j'ai un problème pour changer la couleur de fond des blocs [ hide][ /hide]
J'utilise PHPBB version 3.0
Quelqu'un a-t-il la solution à ce problème?

Merci d'avance

_________________
Le savoir n'est pas aussi important que la compréhension que son application apporte
avatar
dragonjoker
Moderateur des Forums
Moderateur des Forums

Masculin
Nombre de messages : 274
Age : 36
Localisation : Nanterre ou Lille, ça dépend

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par Ty-annna le Mar 20 Nov - 19:51

Salut,
La balise [hide] utilise le meme fond que les citations. Tu peux les modifier dans Panneau d'administration > Thème > Couleurs, et dans le CSS (si tu es en édition avancé) c'est la class .quote

Voilà, dis nous si ça fonctionne, merci.

_________________
avatar
Ty-annna
Administrateur
Administrateur

Féminin
Nombre de messages : 1989
Age : 41
Localisation : 95
Loisirs : lire, informatique

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par dragonjoker le Mar 20 Nov - 19:56

Il semblerait que justement la balise [ hide] n'utilise pas le même fond que les citations, en effet mes citations ont un fond noir alors que les blocs [ hide] sont en blanc, sachant que je n'ai aucun fond défini en blanc, je me demande ce qu'il se passe.

_________________
Le savoir n'est pas aussi important que la compréhension que son application apporte
avatar
dragonjoker
Moderateur des Forums
Moderateur des Forums

Masculin
Nombre de messages : 274
Age : 36
Localisation : Nanterre ou Lille, ça dépend

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par Ty-annna le Mar 20 Nov - 19:58

Je regarde de mon coté.

_________________
avatar
Ty-annna
Administrateur
Administrateur

Féminin
Nombre de messages : 1989
Age : 41
Localisation : 95
Loisirs : lire, informatique

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par Ty-annna le Mar 20 Nov - 20:03

Je double post désolée.

De mon coté c'est bien: La balise [hide] utilise le meme fond que les citations. Tu peux les
modifier dans Panneau d'administration > Thème > Couleurs, et
dans le CSS (si tu es en édition avancé) c'est la class .quote.

_________________
avatar
Ty-annna
Administrateur
Administrateur

Féminin
Nombre de messages : 1989
Age : 41
Localisation : 95
Loisirs : lire, informatique

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par dragonjoker le Mer 21 Nov - 12:14

arf, il doit donc y avoir un problème...

_________________
Le savoir n'est pas aussi important que la compréhension que son application apporte
avatar
dragonjoker
Moderateur des Forums
Moderateur des Forums

Masculin
Nombre de messages : 274
Age : 36
Localisation : Nanterre ou Lille, ça dépend

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par Ty-annna le Mer 21 Nov - 16:31

Salut,
Je t'ai répondu par MP.

_________________
avatar
Ty-annna
Administrateur
Administrateur

Féminin
Nombre de messages : 1989
Age : 41
Localisation : 95
Loisirs : lire, informatique

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par dragonjoker le Lun 26 Nov - 18:31

Bon, j'ai résolu mon problème, en éditant directement le CSS, la classe à modifier est 'codebox'

_________________
Le savoir n'est pas aussi important que la compréhension que son application apporte
avatar
dragonjoker
Moderateur des Forums
Moderateur des Forums

Masculin
Nombre de messages : 274
Age : 36
Localisation : Nanterre ou Lille, ça dépend

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par ChrisM@ster le Lun 26 Nov - 19:04

dragonjoker a écrit:Bon, j'ai résolu mon problème, en éditant directement le CSS, la classe à modifier est 'codebox'

c'est une classe que tu as rajouté ?

_________________
avatar
ChrisM@ster
Administrateur
Administrateur

Masculin
Nombre de messages : 3384
Age : 43
Localisation : Jamais bien loin ^^
Loisirs : Informatique - PLUS DE SUPPORT PAR MP

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par dragonjoker le Lun 26 Nov - 19:12

non, c'est une classe déjà existante. Pour la trouver, j'ai ouvert mon forum avec Firefox, j'ai affiché la source, puis j'ai effectué une recherche sur le texte contenu dans la balise [ hide], j'ai trouvé la classe utilisée : 'codebox'. Enfin, dans le .css, j'ai changé le fond de cette balise codebox et ai obtenu le résultat que je voulais.

_________________
Le savoir n'est pas aussi important que la compréhension que son application apporte
avatar
dragonjoker
Moderateur des Forums
Moderateur des Forums

Masculin
Nombre de messages : 274
Age : 36
Localisation : Nanterre ou Lille, ça dépend

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par ChrisM@ster le Lun 26 Nov - 19:17

Je te posais cette question car en principe le hide doit prendre les meme attributs que la classe de citation...

Codebox est la classe relative à la balise code (enfin sur nos deux forums c'est comme ça)... étonnant... mais puisque ça fonctionne ainsi temps mieux...

_________________
avatar
ChrisM@ster
Administrateur
Administrateur

Masculin
Nombre de messages : 3384
Age : 43
Localisation : Jamais bien loin ^^
Loisirs : Informatique - PLUS DE SUPPORT PAR MP

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par dragonjoker le Lun 26 Nov - 19:30

Le plus intéressant est que même si je modifiais la balise code sans passer par le CSS ça ne changeait pas la couleur de la balise hide...
Je ne sais pas comment fonctionne leur truc.

_________________
Le savoir n'est pas aussi important que la compréhension que son application apporte
avatar
dragonjoker
Moderateur des Forums
Moderateur des Forums

Masculin
Nombre de messages : 274
Age : 36
Localisation : Nanterre ou Lille, ça dépend

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par ChrisM@ster le Lun 26 Nov - 19:33

dragonjoker a écrit:Le plus intéressant est que même si je modifiais la balise code sans passer par le CSS ça ne changeait pas la couleur de la balise hide...
Je ne sais pas comment fonctionne leur truc.

Pour pas mal de truc c'est comme ça... ya pas mal de dysfonctionnement sur la PHPBB3...

Enfin bref, c'est un sujet résolu

_________________
avatar
ChrisM@ster
Administrateur
Administrateur

Masculin
Nombre de messages : 3384
Age : 43
Localisation : Jamais bien loin ^^
Loisirs : Informatique - PLUS DE SUPPORT PAR MP

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par ChrisM@ster le Mar 27 Nov - 17:10

Je remonte ce sujet (désolé pour le double post) mais après avoir pris des informations auprès de Ty-annna et Chiroki voici ce qui est ressorti concernant ce problème:

Ty annna s'est connectée à ton forum et a vérifié ton CSS et n'a rien trouvé d'anormal.

Chiroki a ensuite pris le relai et a effectué exactement la même manipulation que toi pour connaitre le nom de la classe qui était appliquée à la balise [hide].

Tout comme toi il a remarqué que la classe codeblock était utilisé pour cette balise.

Il a effectué un changement de couleur dans le CSS avancé de ton forum pour constater si un changement intervenait en procédant comme ça... sans succès...

Alors ce que je voudrais savoir c'est si tu avais installé un script dans la description du site ? (Ty-annna me dit t'avoir demandé cette info par MP mais tu sembles ne pas avoir vu le message)

_________________
avatar
ChrisM@ster
Administrateur
Administrateur

Masculin
Nombre de messages : 3384
Age : 43
Localisation : Jamais bien loin ^^
Loisirs : Informatique - PLUS DE SUPPORT PAR MP

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par dragonjoker le Mar 27 Nov - 18:50

je n'ai installé aucun script, par contre je ne sais pas si l'autre admin ne l'a pas fait.
Ou peut on trouver les scripts deja existants?

_________________
Le savoir n'est pas aussi important que la compréhension que son application apporte
avatar
dragonjoker
Moderateur des Forums
Moderateur des Forums

Masculin
Nombre de messages : 274
Age : 36
Localisation : Nanterre ou Lille, ça dépend

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par ChrisM@ster le Mar 27 Nov - 21:25

dragonjoker a écrit:je n'ai installé aucun script, par contre je ne sais pas si l'autre admin ne l'a pas fait.
Ou peut on trouver les scripts deja existants?

En général, on peut placer des scripts à quatre endroits sur les forums ForumActif:

1- Dans la description du site. (Panneau d'administration / Général / Configuration)

2- Dans le bloc message de la page d'accueil. (Panneau d'administration / Général / Configuration)

3- Dans le bloc metatags. (Panneau d'administration / Général / Configuration)

4- Dans un module du portail. (Panneau d'administration / Module / Portail & Calendrier / Structures du portail )

_________________
avatar
ChrisM@ster
Administrateur
Administrateur

Masculin
Nombre de messages : 3384
Age : 43
Localisation : Jamais bien loin ^^
Loisirs : Informatique - PLUS DE SUPPORT PAR MP

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par dragonjoker le Mer 28 Nov - 11:45

Dans ce cas il n'y a aucun script sur mon forum

_________________
Le savoir n'est pas aussi important que la compréhension que son application apporte
avatar
dragonjoker
Moderateur des Forums
Moderateur des Forums

Masculin
Nombre de messages : 274
Age : 36
Localisation : Nanterre ou Lille, ça dépend

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par ChrisM@ster le Ven 30 Nov - 11:07

dragonjoker a écrit:Dans ce cas il n'y a aucun script sur mon forum

Alors dans ce cas il devait s'agir d'un bug...

PROBLEME RESOLU

_________________
avatar
ChrisM@ster
Administrateur
Administrateur

Masculin
Nombre de messages : 3384
Age : 43
Localisation : Jamais bien loin ^^
Loisirs : Informatique - PLUS DE SUPPORT PAR MP

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème de couleurs

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum